просит драйвер с другим именем

Обсуждение статьи "Установка Windows XP по сети. RIS, но не Microsoft"

Модераторы: editor, Devils

просит драйвер с другим именем

Сообщение gentenaar » 01 мар 2007, 12:49

Честное слово не знал как назвать тему потому как сама суть проблемы мне не ясна (была бы ясна наверное не постил бы здесь)

Инсталлирую Windows XP SP2 на Packard Bell EasyNote R3320, так как родной драйвет с оффсайта uli_ethernet_340.exe мне не удалось ни распаковать, ни скопировать файлы *.inf и *.sys из временной папки (их там просто не присутствует, ну или я слепой) то я выяснил что LAN у этого ноутбука на чипсете M1573 Ethernet Controller от ULI и отыскал на оффсайте http://www.uli.com.tw/eng/support/drivers.php драйвера ftp://www.uli.com.tw/driver/Integrated220.rar для чипсета где присутствовала папка LAN (вроде то что мне нужно) в которой есть подпапки с драйверами под разные OS Windows.

Файл Netuli.inf идентичен во всех папках, то есть для всех драйверов а, файлы .*sys имеют разные имена (естественно) для XP имя файла ULILAN51.sys, так вот, в процессе первичной загрузки драйверов я вижу http://unattendedxp.com/articles/wxpris ... ver-en.png (требует файл ULILAN.sys), вроде проблема решаема и описана в борьбе с ошибками, но суть в том, что это драйвер windows 2000 и при использовании его после этого скрина http://unattendedxp.com/articles/wxpris ... ect-en.png компьютер падает в BSOD с ошибкой 0х000000BB

лог binlsrv.py

E:\NETBOOT\RIS-LINUX>infparser.py E:\NETBOOT\WINXPSP2\DRIVERS
Compiled 1355 drivers
generated devlist.cache
generated nics.txt

E:\NETBOOT\RIS-LINUX>binlsrv.py
Succesfully loaded 1355 devices
Binlserver started... pid 624
Recv NCQ len = 48
NCQ Driver request
[R] Mac address 00:40:d0:7a:fb:35
[R] Vid: 0x10b9
[R] Pid: 0x5263
[R] rev_u1 = 0x2
[R] rev_u2 = 0x0
[R] rev_u3 = 0x0
[R] rev = 0x0
[R] rev2 = 0xd8
[R] subsys = 0x526310b9
[R] Source path: \\192.168.200.1\WINXPSP2\INSTALL
Checking PCI\VEN_10B9&DEV_5263&SUBSYS_526310B9
Found PCI\VEN_10B9&DEV_5263&SUBSYS_526310B9 in E:\NETBOOT\WINXPSP2\DRIVERS\Netul
i.inf
[S] Packet len = 0xc6 (198)
[S] Result code: 0x0
[S] type: 0x2
[S] base offset = 0x24 (36)
[S] drv_off = 0x70 (112)
[S] srv_off: 0x86 (134) -> 126 from start
[S] plen: 0x38 (56)
[S] p_off: 0x96 (150) -> 142 from start
[S] hid: PCI\VEN_10B9&DEV_5263&SUBSYS_526310B9 - Len 0x25 (37)
[S] drv: ULILAN.SYS - Len 0xa (10)
[S] srv: ULI5261 - Len 0x7 (7)
[S] Description (REG_EXPAND_SZ [2]) = NoDesc
[S] Characteristics (REG_SZ [1]) = 132
[S] BusType (REG_SZ [1]) = 5
[S] Total Params: 3
Если это возможно, не могли бы Вы как можно скорее ответить как можно решить эту проблему

С уважением,
abdij
gentenaar
 
Сообщения: 2
Зарегистрирован: 01 мар 2007, 11:51

Сообщение root » 01 мар 2007, 22:03

Найти строку в файле LAN\winxp\Netuli.inf
Код: Выделить всё
[ULICOM]
заменить на
Код: Выделить всё
[aULICOM]
root
Site Admin
 
Сообщения: 439
Зарегистрирован: 20 июл 2006, 00:45

Сообщение Гость » 01 мар 2007, 23:52

прошу прощения за навязчивость но изменения в файле NETULI приводят к BSOD в ситуации аналогичной той которую я описал в первом посту


вот лог binlsrv

E:\NETBOOT\RIS-LINUX>binlsrv.py
Succesfully loaded 914 devices
Binlserver started... pid 3516
Recv NCQ len = 48
NCQ Driver request
[R] Mac address 00:40:d0:7a:fb:35
[R] Vid: 0x10b9
[R] Pid: 0x5263
[R] rev_u1 = 0x2
[R] rev_u2 = 0x0
[R] rev_u3 = 0x0
[R] rev = 0x0
[R] rev2 = 0xd8
[R] subsys = 0x526310b9
[R] Source path: \\192.168.200.1\WINXPSP2\INSTALL
Checking PCI\VEN_10B9&DEV_5263&SUBSYS_526310B9
Found PCI\VEN_10B9&DEV_5263&SUBSYS_526310B9 in E:\NETBOOT\WINXPSP2\DRIVERS\Netul
i.inf
[S] Packet len = 0xce (206)
[S] Result code: 0x0
[S] type: 0x2
[S] base offset = 0x24 (36)
[S] drv_off = 0x70 (112)
[S] srv_off: 0x8a (138) -> 130 from start
[S] plen: 0x38 (56)
[S] p_off: 0x9e (158) -> 150 from start
[S] hid: PCI\VEN_10B9&DEV_5263&SUBSYS_526310B9 - Len 0x25 (37)
[S] drv: ULILAN51.SYS - Len 0xc (12)
[S] srv: ULI5261XP - Len 0x9 (9)
[S] Description (REG_EXPAND_SZ [2]) = NoDesc
[S] Characteristics (REG_SZ [1]) = 132
[S] BusType (REG_SZ [1]) = 5
[S] Total Params: 3

ума не приложу что делать

с уважением,
abdij
Гость
 

Сообщение root » 02 мар 2007, 10:36

Попробуй использовать драйвера uli_ethernet_340.exe. Для распаковки можно воспользоваться утилитой Inno Setup Unpacker
Или же как вариант запускаешь uli_ethernet_340.exe производишь инсталяцию. На диске %SystemRoot% будет находиться директроия pnp. Вот в ней и лежат драйвера.
А как полностью называеться BSOD?
root
Site Admin
 
Сообщения: 439
Зарегистрирован: 20 июл 2006, 00:45

Сообщение gentenaar » 02 мар 2007, 15:15

A problem has been detected and windows has been shut down to prevent damage to you computer

An initialization failure occurred while attempting to boot from the network.

If this is the first time you’ve seen this stop error screen,
restart you computer. If this screen appears again, follow these steps:

Check to make sure any new hardware or software is properly installed.
If this is a new installation, ask you hardware or software manufacturer for any windows updates you might need.

If problem continue, disable or remove any newly installed hardware of software. Disable bios memory options such as caching or shadowing. If you need to safe mode to remove or disable components, restart you computer, press F8 to select advanced Startup Options, and then select safe mode.

Technical information:

*** STOP: 0x000000BB (0x00000003, 0xC00000C0, 0x00000000, 0x00000000)

log binlsrv.py

E:\NETBOOT\RIS-LINUX>binlsrv.py
Succesfully loaded 914 devices
Binlserver started... pid 3992
Recv NCQ len = 48
NCQ Driver request
[R] Mac address 00:40:d0:7a:fb:35
[R] Vid: 0x10b9
[R] Pid: 0x5263
[R] rev_u1 = 0x2
[R] rev_u2 = 0x0
[R] rev_u3 = 0x0
[R] rev = 0x0
[R] rev2 = 0xd8
[R] subsys = 0x526310b9
[R] Source path: \\192.168.200.1\WINXPSP2\INSTALL
Checking PCI\VEN_10B9&DEV_5263&SUBSYS_526310B9
Found PCI\VEN_10B9&DEV_5263&SUBSYS_526310B9 in E:\NETBOOT\WINXPSP2\DRIVERS\Netul
i.inf
[S] Packet len = 0xc6 (198)
[S] Result code: 0x0
[S] type: 0x2
[S] base offset = 0x24 (36)
[S] drv_off = 0x70 (112)
[S] srv_off: 0x86 (134) -> 126 from start
[S] plen: 0x38 (56)
[S] p_off: 0x96 (150) -> 142 from start
[S] hid: PCI\VEN_10B9&DEV_5263&SUBSYS_526310B9 - Len 0x25 (37)
[S] drv: ULILAN.SYS - Len 0xa (10)
[S] srv: ULI5261 - Len 0x7 (7)
[S] Description (REG_EXPAND_SZ [2]) = NoDesc
[S] Characteristics (REG_SZ [1]) = 132
[S] BusType (REG_SZ [1]) = 5
[S] Total Params: 3

спасибо за распаковщик Inno Setup Unpacker, честное слово сам тоже искал но не нашел.

с уважением,
abdij

это уже опыты с драйвером из uli_ethernet_340.exe
gentenaar
 
Сообщения: 2
Зарегистрирован: 01 мар 2007, 11:51

Сообщение root » 02 мар 2007, 16:42

Вот здесь была похожая ситуация. Решилась поиском новых драйверов.
Что делать Вам даже не могу подсказать. Ясно одно эти драйаера не подходят.
root
Site Admin
 
Сообщения: 439
Зарегистрирован: 20 июл 2006, 00:45


Вернуться в Установка Windows XP по сети. RIS, но не Microsoft

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 1

cron
@Mail.ru