Проблема с драйверами

Обсуждение статьи "Установка Windows XP по сети. RIS, но не Microsoft"

Модераторы: editor, Devils

Проблема с драйверами

Сообщение alexus_26 » 18 янв 2010, 11:50

Доброго времени суток всем. Спасибо огромное авторам статей. Нервы действительно сберегают ваши советы. Теперь к делу.
1) Ставлю винду по сети, но на виртуальную машину. TFTPD сервер работает, адреса раздает, файлы загружаются. Проблема возникает тогда, когда появляется синий экран, где написано "Установка Windows". Система подвисает на несколько минут, внизу строка состояния говорит "Подождите", а потом выдает, что система не смогла найти в предлагаемом образе драйвера сетевых устройств . Образ рабочий, с диска все устанавливается на ура (еще раз спасибо авторам). Этот же образ, но при доработке для установки по сети не ставится.
2)В логах TFTPD я нашел, что он система не могла найти файлы \INSTALL\I386\migrate.inf и \INSTALL\I386\unsupdrv.inf. Про первый файл я нашел инфу, но содержимое - нет, поэтому я просто подсунул в директорию пустой файл с нужным именем. Второй файл имеет у меня следующее содержание:
Код: Выделить всё
[Version]
Signature = "$Windows NT$"

[AddReg.ax02l71h]
[Files.ax02l71h]
ax02l71h.sys,system32\drivers
[HardwareIds.ax02l71h]
*PNPA000=ax02l71h
ACPI\PNPA000=ax02l71h
[Devices]
ax02l71h


Его я тоже подсунул, но толку мало. Что я не так сделал?
P.S. Извините, что много написал, просто хотел более подробно описать проблему =)
alexus_26
 
Сообщения: 4
Зарегистрирован: 18 янв 2010, 11:38

Re: Проблема с драйверами

Сообщение Devils » 18 янв 2010, 17:33

То что подробно - хорошо. Проблема в том, что в этот момент
внизу строка состояния говорит "Подождите"
система ищет драйвер сетевой карты в базе драйверов, которую вы создавали с помощью программ infparser.py и binlsrv.py. Так вот, видимо вашей сетевой карты в этой базе нет. Добавить его очень легко. Когда выдает ошибку, что образ не верный, посмотрите что пишет программа binlsrv.py. Вы увидете строку примерно такого содержания PCI\VEN_10EC&DEV_8168&SUBSYS_16D51043&REV_01. Далее копируете VEN_10EC&DEV_8168 (VEN-Vendor-Изготовитель. DEV-Device-устройство) и вставляете сюда для поиска. А после копируете скачанные и разархивированные драйвера согласно статье.
Devils
 
Сообщения: 231
Зарегистрирован: 25 июн 2009, 16:40
Откуда: Подмосковье

Re: Проблема с драйверами

Сообщение qw-0 » 18 янв 2010, 23:40

alexus_26 писал(а):Доброго времени суток всем. Спасибо огромное авторам статей. Нервы действительно сберегают ваши советы. Теперь к делу.
1) Ставлю винду по сети, но на виртуальную машину. TFTPD сервер работает, адреса раздает, файлы загружаются. Проблема возникает тогда, когда появляется синий экран, где написано "Установка Windows". Система подвисает на несколько минут, внизу строка состояния говорит "Подождите", а потом выдает, что система не смогла найти в предлагаемом образе драйвера сетевых устройств . Образ рабочий, с диска все устанавливается на ура (еще раз спасибо авторам). Этот же образ, но при доработке для установки по сети не ставится.

Если виртуальная машина vmware 6.5, то проблем не должно возникнуть. Единственное, может возникнуть проблема при использовании в настройками виртуальной машины (*.vmx) параметра ethernet0.virtualDev со значение vmxnet. А так по умолчанию, для Windows XP Profesional подходят стандартные драйвера из дистрибутива.
alexus_26 писал(а):2)В логах TFTPD я нашел, что он система не могла найти файлы \INSTALL\I386\migrate.inf и \INSTALL\I386\unsupdrv.inf. Про первый файл я нашел инфу, но содержимое - нет, поэтому я просто подсунул в директорию пустой файл с нужным именем. Второй файл имеет у меня следующее содержание:

Эти ошибки можно проигнорировать.
qw-0
 
Сообщения: 164
Зарегистрирован: 13 апр 2007, 01:20

Re: Проблема с драйверами

Сообщение alexus_26 » 19 янв 2010, 08:20

2 Devils

В качестве TFTPD сервера я использую TFTPD32.exe, для него тоже надо использовать программы infparser.py и binlsrv.py? В статье я ничего про это не нашел? только при использовании программы RIS-linux.

2 qw-0

Я использую VirtualBox. Может поэтому не работает? Я уже пытался из рабочей виртуалки выдрать драйвера и подсунуть их в установочную папку, но не помогло.
alexus_26
 
Сообщения: 4
Зарегистрирован: 18 янв 2010, 11:38

Re: Проблема с драйверами

Сообщение alexus_26 » 19 янв 2010, 19:56

Все, проблема решена. Спасибо всем, кто помогал мне в поисках ее решения. Решение оказалось банальным - НАДО ВНИМАТЕЛЬНО ЧИТАТЬ ИНСТРУКЦИЮ!!!!!!!!
alexus_26
 
Сообщения: 4
Зарегистрирован: 18 янв 2010, 11:38


Вернуться в Установка Windows XP по сети. RIS, но не Microsoft

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 1

cron
@Mail.ru