установка XP на Acer Aspire M3640

Обсуждение статьи "Установка Windows XP по сети. RIS, но не Microsoft"

Модераторы: editor, Devils

установка XP на Acer Aspire M3640

Сообщение mip06 » 09 ноя 2009, 22:54

При поптыке поставить ХП на системник Acer Aspire M3640.
Понял что есть определенные проблеммы.

Например первая это поиск подходящих RIS драйверов, несолько часов поиска и я нашел: NVIDIA MCP73 RIS 6753 (http://www.nforcershq.com/forum/new-nforce-drivers-for-vista-and-xp-32-64bit-at-asus-t70908.html).

Вторая проблемма, установшик просто не видит дисков, при чем это так странно сообщает, что я раньше этого не видел.
Интеграция txtsetup.oem в TXTSETUP.SIF из пакета FDD_F6_sata_raid(1).zip почемуто не помогла. При инициализации устройств
Код: Выделить всё
NVIDIA RAID Driver (required)
NVIDIA nForce Storage Controller (required)
подвисает установшик

P.S. Ссылка на РИС дрова может кому пригодится. Ну и я прошу помощи.
mip06
 
Сообщения: 34
Зарегистрирован: 27 дек 2006, 18:04

Разместил в $OEM%\Textmode образ дискеты FDD_F6_sata_raid(1)

Сообщение mip06 » 10 ноя 2009, 17:28

Разместил в $OEM%\Textmode образ дискеты FDD_F6_sata_raid(1).zip
Добавляю в winnt.sif
Код: Выделить всё
[MassStorageDrivers]
"NVIDIA nForce Storage Controller (required)" = "OEM"
"NVIDIA RAID Driver (required)" = "OEM"
"IDE CD-ROM (ATAPI 1.2)/PCI IDE-Є®­ва®««Ґа" = "RETAIL"

Содержимое файла txtsetup.oem
Код: Выделить всё
[Disks]
d1 = "NVIDIA RAID DRIVER (SCSI)",\disk1,\

[Defaults]
scsi = RAIDCLASS

[scsi]
RAIDCLASS = "NVIDIA RAID Driver (required)"
BUSDRV = "NVIDIA nForce Storage Controller (required)"

[Files.scsi.RAIDCLASS]
driver  = d1,nvrd32.sys,RAIDCLASS
inf     = d1,nvrd32.inf
catalog = d1,nvraid.cat
dll     = d1,nvraidco.dll

[Files.scsi.BUSDRV]
driver = d1,nvgts.sys,BUSDRV
inf    = d1, nvrd32.inf
catalog = d1, nvraid.cat
dll    = d1,nvraidco.dll

[Config.RAIDCLASS]

[Config.BUSDRV]
value = parameters\PnpInterface,5,REG_DWORD,1


[HardwareIds.scsi.RAIDCLASS]
id = "SCSI\NVIDIA__Raid_Disk________","nvrd32"
id = "SCSI\__NVIDIA_______Raid_Disk","nvrd32"
id = "SCSI\NVIDIA__Raid_Disk_20_____","nvrd32"
id = "SCSI\__NVIDIA____Raid_Disk_20","nvrd32"
id = "*_NVRAIDBUS","nvrd32"
id = "*NVRAIDBUS","nvrd32"
id = "*NVRAID20","nvrd32"

[HardwareIds.scsi.BUSDRV]
id = "PCI\VEN_10DE&DEV_0036", "nvgts" ; MCP04 SATA1
id = "PCI\VEN_10DE&DEV_003E", "nvgts" ; MCP04 SATA2
id = "PCI\VEN_10DE&DEV_0054", "nvgts" ; CK804 SATA1
id = "PCI\VEN_10DE&DEV_0055", "nvgts" ; CK804 SATA2
id = "PCI\VEN_10DE&DEV_0266", "nvgts" ; MCP51 SATA1
id = "PCI\VEN_10DE&DEV_0267", "nvgts" ; MCP51 SATA2
id = "PCI\VEN_10DE&DEV_036F", "nvgts" ; MCP55 OEM
id = "PCI\VEN_10DE&DEV_037E", "nvgts" ; MCP55 CHANNEL
id = "PCI\VEN_10DE&DEV_037F", "nvgts" ; MCP55 UNUSED
id = "PCI\VEN_10DE&DEV_03F6", "nvgts" ; MCP61 OEM
id = "PCI\VEN_10DE&DEV_03F7", "nvgts" ; MCP61 CHANNEL
id = "PCI\VEN_10DE&DEV_03E7", "nvgts" ; MCP61 NSIP
id = "PCI\VEN_10DE&DEV_044C", "nvgts" ; MCP65 RAID
id = "PCI\VEN_10DE&DEV_0558", "nvgts" ; MCP67 RAID, OEM
id = "PCI\VEN_10DE&DEV_0559", "nvgts" ; MCP67 RAID, CHANNEL
id = "PCI\VEN_10DE&DEV_055A", "nvgts" ; MCP67 RAID, NBP
id = "PCI\VEN_10DE&DEV_07F8", "nvgts" ; MCP73 RAID 1
id = "PCI\VEN_10DE&DEV_07F9", "nvgts" ; MCP73 RAID 2
id = "PCI\VEN_10DE&DEV_07FA", "nvgts" ; MCP73 RAID 3
id = "PCI\VEN_10DE&DEV_07FB", "nvgts" ; MCP73 RAID 4
id = "PCI\VEN_10DE&DEV_0AD8", "nvgts" ; MCP77 RAID 1

Установщик винды ну шаге после черного экрана уже говорит:
Программа установки обнаружила ошибку в файле, посовляемым изготовителем оборудования, или этот файл поврежден.
Не правильные или отсуствующие типы файлов указанные в секции
Files.SCSI.BUSDRV
mip06
 
Сообщения: 34
Зарегистрирован: 27 дек 2006, 18:04

Сообщение mip06 » 10 ноя 2009, 18:00

УРА!!!!!!!!!!
Я удалил из веток [Files.scsi.RAIDCLASS] и [Files.scsi.BUSDRV] инфу о dll и cat файлах.
Инсталятор увидел диск.
Сейчас попытаюсь поставить винду.
mip06
 
Сообщения: 34
Зарегистрирован: 27 дек 2006, 18:04

Сообщение mip06 » 10 ноя 2009, 21:28

Во время Графической части установки все отлично, даже можно диски посмотреть (Shift+F10, notepad.exe, Open).
Но после первой перезагрузки, когда должна уже винда запускаться, появляется лэйбол (флаг) Майкрософт, комп зависает в Синий экран, ошибка 0x07b. Видать диски не видет.
Не понимаю разве я кудато не скопировал дрова на винт?
mip06
 
Сообщения: 34
Зарегистрирован: 27 дек 2006, 18:04

Сообщение Devils » 10 ноя 2009, 21:51

mip06 Конечно у тебя выдаст BSOD. т.к. для текстового режима ты драйвера подставил, а для графического нет.
Делается это так:
1. В папке "$OEM$" Создаем папку "$1", Далее папку допустим "D"(Чем короче название папки тем лучше. Далее скидываются .inf и .sys файлы.
2. в файле winnt.sif В секции [Unattended] добавьте следующую строку:
OemPnPDriversPath="D"
Пример:
Код: Выделить всё
[Unattended]
OemPnPDriversPath="D\M\3;D\M\3B;D\M\3C;D\M\A;D\M\A2;D\M\A3;D\M\A4;D\M\A5;D\M\A6;D\M\A7;D\M\A8;D\M\AD1;D\M\AD2;D\M\AD3;D\M\AD4;D\M\AD5;D\M\AD6;D\M\AD7;D\M\AD8;D\M\AD9;D\M\ADA;D\M\ADB;D\M\ADC;D\M\AM"
Devils
 
Сообщения: 231
Зарегистрирован: 25 июн 2009, 16:40
Откуда: Подмосковье

Сообщение mip06 » 10 ноя 2009, 22:19

Devils писал(а):mip06 Конечно у тебя выдаст BSOD. т.к. для текстового режима ты драйвера подставил, а для графического нет.
Делается это так:
1. В папке "$OEM$" Создаем папку "$1", Далее папку допустим "D"(Чем короче название папки тем лучше. Далее скидываются .inf и .sys файлы.
2. в файле winnt.sif В секции [Unattended] добавьте следующую строку:
OemPnPDriversPath="D"
Пример:
Код: Выделить всё
[Unattended]
OemPnPDriversPath="D\M\3;D\M\3B;D\M\3C;D\M\A;D\M\A2;D\M\A3;D\M\A4;D\M\A5;D\M\A6;D\M\A7;D\M\A8;D\M\AD1;D\M\AD2;D\M\AD3;D\M\AD4;D\M\AD5;D\M\AD6;D\M\AD7;D\M\AD8;D\M\AD9;D\M\ADA;D\M\ADB;D\M\ADC;D\M\AM"
Большое Спасибо за ответ!!! Так приятно видить живого человека!
Уже 3й день вожусь с компом, ни как не получается.

В файле winnt.sif у меня есть такая строчка
Код: Выделить всё
[Unattended]
AutoActivate=No
DUDisable = Yes
CrashDumpSetting=0
DriverSigningPolicy=Ignore
FactoryMode=No
FileSystem=*
Repartition=No
OemPreinstall=Yes
OemPnPDriversPath="Drivers\mip08nic;Drivers\mip08ata;Drivers\mip08vga"
OemSkipEula=Yes

Файлы в папку $OEM$\$1\drivers\mip08ata я скинул.
Проблема на месте.
Последний раз редактировалось mip06 10 ноя 2009, 22:31, всего редактировалось 1 раз.
mip06
 
Сообщения: 34
Зарегистрирован: 27 дек 2006, 18:04

Сообщение mip06 » 10 ноя 2009, 22:31

Devils писал(а):Далее скидываются .inf и .sys файлы.
У меня есть несколько наборов драверов, какие скидывать?
Такой набор:
Код: Выделить всё
disk1
nvgts.sys
nvide.nvu
nvraid.cat
nvraidco.dll
NvRCoAr.dll
NvRCoCs.dll
NvRCoDa.dll
NvRCoDe.dll
NvRCoEl.dll
NvRCoEng.dll
NvRCoEnu.dll
NvRCoEs.dll
NvRCoEsm.dll
NvRCoFi.dll
NvRCoFr.dll
NvRCoHe.dll
NvRCoHu.dll
NvRCoIt.dll
NvRCoJa.dll
NvRCoKo.dll
NvRCoNl.dll
NvRCoNo.dll
NvRCoPl.dll
NvRCoPt.dll
NvRCoPtb.dll
NvRCoRu.dll
NvRCoSk.dll
NvRCoSl.dll
NvRCoSv.dll
NvRCoTh.dll
NvRCoTr.dll
NvRCoZhc.dll
NvRCoZht.dll
nvrd32.inf
nvrd32.sys
txtsetup.oem
mip06
 
Сообщения: 34
Зарегистрирован: 27 дек 2006, 18:04

Сообщение mip06 » 10 ноя 2009, 22:35

И такой набор FDD_F6_sata_raid(1).zip, его я и использую в textmode:
Код: Выделить всё
disk1
idecoi.dll
nvgts.sys
nvide.nvu
nvraid.cat
nvraidco.dll
nvrd32.inf
nvrd32.sys
txtsetup.oem


Я пробывал оба набора копировать в $OEM$\$1\drivers\mip08ata, но не помогло. Почему? Может нужно какие то файлы удалить? Например в textmode винта не было видно, пока я не удалил в textmode.oem строку подключающую dll
mip06
 
Сообщения: 34
Зарегистрирован: 27 дек 2006, 18:04

Сообщение mip06 » 10 ноя 2009, 22:36

И такой набор FDD_F6_sata_raid(1).zip, его я и использую в textmode:
Код: Выделить всё
disk1
idecoi.dll
nvgts.sys
nvide.nvu
nvraid.cat
nvraidco.dll
nvrd32.inf
nvrd32.sys
txtsetup.oem
Последний раз редактировалось mip06 10 ноя 2009, 22:37, всего редактировалось 1 раз.
mip06
 
Сообщения: 34
Зарегистрирован: 27 дек 2006, 18:04

Сообщение mip06 » 10 ноя 2009, 22:37

Я пробывал оба набора копировать в $OEM$\$1\drivers\mip08ata, но не помогло. Почему?
Может нужно какие то файлы удалить?
Например в textmode винта не было видно, пока я не удалил в textmode.oem строку подключающую dll
mip06
 
Сообщения: 34
Зарегистрирован: 27 дек 2006, 18:04

След.

Вернуться в Установка Windows XP по сети. RIS, но не Microsoft

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron
@Mail.ru