Ошибка 21. Плата nvidia

Обсуждение статьи "Установка Windows XP по сети. RIS, но не Microsoft"

Модераторы: editor, Devils

Ошибка 21. Плата nvidia

Сообщение _alexander_ » 29 апр 2008, 16:44

У меня работает на ASPLinux 11.2.

Все машины, за исключением HP Workstation xw9400, загружаютя и происходит установка ХР.

Ошибка при использовании xw9400 заключается в:

"INF-файл иw* испорчен или отсутствует, состояние 21.",
где * - символ, который невозможно набрать с клавиатуры.
Причем в имени файла, отображаемом на экране при ошибке, присутствует русская буква "и". Именно так.

Т.е. появляется сообщение "Программа установки проверяет конфигурацию оборудования", и затем следует эта ошибка.


В xw9400 сетевые платы от nvidia.

Скачал и установил NVIDIA nForce Network Drivers for Microsoft Remote Installation Service c ftp://ftp.hp.com/pub/softpaq/sp33501-34000/sp33970.exe согласно http://h20000.www2.hp.com/bizsupport/Te ... nvOID=1093

Разместил inf-файл там же, где размещал inf'ы для других сетевых плат.
Также, качал архив для nvidia, как и в статье, http://dlsvr02.asus.com/pub/ASUS/misc/u ... S_V916.zip
Результат тот же (в принципе и содержимое архива такое же, как и предложенное от HP :)

Выполнил ./infparser.py /путь/
Где как обычно сообщилось количество устройств и создались devlist.cache и nics.txt.

*.sys от скаченных RIS-драйверов скопировал в /reminst/i386

Логов tftp-hpa нигде не могу найти. Как в линухе, так и путь к ним в инете. Используемая версия tftp-hpa 0.48.
Логи BINL ничего не сообщают. Будто бы никто из tftp-клиентов и не обращался за производителем и моделью сетевой платы.

В общем, сабж. Руки вроде оттуда растут. Тем более, что со всеми машинами, которые не хотели грузиться, я разобрался банальным добавлением *.inf с последующей работой infparser.py и копированием *.sys в i386.
С этими станциями - не получается.
У кого какие мысли?
_alexander_
 
Сообщения: 23
Зарегистрирован: 29 апр 2008, 16:34
Откуда: Новый Уренгой

Re: Ошибка 21. Плата nvidia

Сообщение root » 29 апр 2008, 20:11

_alexander_ писал(а):У меня работает на ASPLinux 11.2.

Все машины, за исключением HP Workstation xw9400, загружаютя и происходит установка ХР.

Ошибка при использовании xw9400 заключается в:

"INF-файл иw* испорчен или отсутствует, состояние 21.",
где * - символ, который невозможно набрать с клавиатуры.
Причем в имени файла, отображаемом на экране при ошибке, присутствует русская буква "и". Именно так.

Т.е. появляется сообщение "Программа установки проверяет конфигурацию оборудования", и затем следует эта ошибка.


В xw9400 сетевые платы от nvidia.

Скачал и установил NVIDIA nForce Network Drivers for Microsoft Remote Installation Service c ftp://ftp.hp.com/pub/softpaq/sp33501-34000/sp33970.exe согласно http://h20000.www2.hp.com/bizsupport/Te ... nvOID=1093

Разместил inf-файл там же, где размещал inf'ы для других сетевых плат.
Также, качал архив для nvidia, как и в статье, http://dlsvr02.asus.com/pub/ASUS/misc/u ... S_V916.zip
Результат тот же (в принципе и содержимое архива такое же, как и предложенное от HP :)

Выполнил ./infparser.py /путь/
Где как обычно сообщилось количество устройств и создались devlist.cache и nics.txt.

*.sys от скаченных RIS-драйверов скопировал в /reminst/i386

Логов tftp-hpa нигде не могу найти. Как в линухе, так и путь к ним в инете. Используемая версия tftp-hpa 0.48.
Логи BINL ничего не сообщают. Будто бы никто из tftp-клиентов и не обращался за производителем и моделью сетевой платы.

Так если BINL молчит, так почему ты думаешь, что проблема с сетевым адаптером NVIDIA. До загрузки драйверов еще дело не дошло.
root
Site Admin
 
Сообщения: 439
Зарегистрирован: 20 июл 2006, 00:45

Сообщение _alexander_ » 29 апр 2008, 21:00

Потому что с дистрибутивом и его настройкой все относительно правильно: несколько машин разной конфигурации (в частности HP d510, dc7100, dc7800, wmware, бук, модели не помню) устанавливают ОС без проблем.
С этой же станцией - даже не успевают подгружаться никакие драйверы. Т.е. можно смело отмести невозможность увидеть HDD. На что еще обратить внимание - я без понятия. Вот и обращаю внимание на сетевую плату.
Tftp судя по всему отработал. Быть может стоит обратить внимание на лог самбы, но это завтра.
_alexander_
 
Сообщения: 23
Зарегистрирован: 29 апр 2008, 16:34
Откуда: Новый Уренгой

Сообщение root » 29 апр 2008, 22:27

Нет, давай сначала лог binlsrv.py.
И лог твоего tftp сервера.
root
Site Admin
 
Сообщения: 439
Зарегистрирован: 20 июл 2006, 00:45

Сообщение _alexander_ » 30 апр 2008, 05:27

binl только последнее, т.к. предыдущие логи были удалены.
Дата создания не лога не изменилась после того как я запустил загрузку по сети с xw9400. Т.е. до binl дело не доходит.

Succesfully loaded 2534 devices
Binlserver started... pid 2890
Recv NCQ len = 48
NCQ Driver request
[R] Mac address 00:1a:4b:8c:01:cd
[R] Vid: 0x8086
[R] Pid: 0x10c4
[R] rev_u1 = 0x2
[R] rev_u2 = 0x0
[R] rev_u3 = 0x0
[R] rev = 0x3
[R] rev2 = 0xc8
[R] subsys = 0x30d8103c
[R] Source path: \\%SERVERNAME%\Reminst\wxp-pro.rus
Checking PCI\VEN_8086&DEV_10C4&SUBSYS_30D8103C
Checking PCI\VEN_8086&DEV_10C4
Found PCI\VEN_8086&DEV_10C4 in e1e5132.inf
[S] Packet len = 0xd0 (208)
[S] Result code: 0x0
[S] type: 0x2
[S] base offset = 0x24 (36)
[S] drv_off = 0x50 (80)
[S] srv_off: 0x68 (104) -> 96 from start
[S] plen: 0x5c (92)
[S] p_off: 0x7c (124) -> 116 from start
[S] hid: PCI\VEN_8086&DEV_10C4 - Len 0x15 (21)
[S] drv: e1e5132.sys - Len 0xb (11)
[S] srv: e1express - Len 0x9 (9)
[S] Description (REG_EXPAND_SZ [2]) = Intel(R) 82562GT 10/100 Network Connection
[S] Characteristics (REG_SZ [1]) = 132
[S] BusType (REG_SZ [1]) = 5
[S] Total Params: 3
Recv NCQ len = 48
NCQ Driver request
[R] Mac address 00:0c:29:91:6a:8a
[R] Vid: 0x1022
[R] Pid: 0x2000
[R] rev_u1 = 0x2
[R] rev_u2 = 0x0
[R] rev_u3 = 0x0
[R] rev = 0x10
[R] rev2 = 0x200
[R] subsys = 0x20001022
[R] Source path: \\%SERVERNAME%\Reminst\wxp-pro.rus
Checking PCI\VEN_1022&DEV_2000&SUBSYS_20001022
Checking PCI\VEN_1022&DEV_2000
Found PCI\VEN_1022&DEV_2000 in netamd2.inf
[S] Packet len = 0xb8 (184)
[S] Result code: 0x0
[S] type: 0x2
[S] base offset = 0x24 (36)
[S] drv_off = 0x50 (80)
[S] srv_off: 0x6a (106) -> 98 from start
[S] plen: 0x4a (74)
[S] p_off: 0x76 (118) -> 110 from start
[S] hid: PCI\VEN_1022&DEV_2000 - Len 0x15 (21)
[S] drv: pcntpci5.sys - Len 0xc (12)
[S] srv: PCnet - Len 0x5 (5)
[S] Description (REG_EXPAND_SZ [2]) = AMD PCNET PCI Ethernet
[S] Characteristics (REG_SZ [1]) = 132
[S] BusType (REG_SZ [1]) = 5
[S] Total Params: 3

Логов tftp-hpa нигде не могу найти.... Штатный tftp-server писал логи, а tftp-hpa - не знаю куда пишет, и пишет ли.

Запуск tftp-hpa осуществляю:

/usr/sbin/./in.tftp -m /etc/tftp.rules - l -s /media/hdb/tftpboot
Где ключ:
s - используется для указания каталога tftpboot,
l - работа в качества демона
m - указание на файл правил

/etc/tftp.rules:

rg \\ /
rg A a
rg B b
rg C c
rg D d
rg E e
rg F f
rg G g
rg H h
rg I i
rg J j
rg K k
rg L l
rg M m
rg N n
rg O o
rg P p
rg Q q
rg R r
rg S s
rg T t
rg U u
rg V v
rg W w
rg X x
rg Y y
rg Z z


man in.tftp - ничего не сказано про логи....
_alexander_
 
Сообщения: 23
Зарегистрирован: 29 апр 2008, 16:34
Откуда: Новый Уренгой

Сообщение root » 30 апр 2008, 08:28

_alexander_ писал(а):binl только последнее, т.к. предыдущие логи были удалены.
Дата создания не лога не изменилась после того как я запустил загрузку по сети с xw9400. Т.е. до binl дело не доходит.

Succesfully loaded 2534 devices
Binlserver started... pid 2890
Recv NCQ len = 48
NCQ Driver request
[R] Mac address 00:1a:4b:8c:01:cd
[R] Vid: 0x8086
[R] Pid: 0x10c4
[R] rev_u1 = 0x2
[R] rev_u2 = 0x0
[R] rev_u3 = 0x0
[R] rev = 0x3
[R] rev2 = 0xc8
[R] subsys = 0x30d8103c
[R] Source path: \\%SERVERNAME%\Reminst\wxp-pro.rus
Checking PCI\VEN_8086&DEV_10C4&SUBSYS_30D8103C
Checking PCI\VEN_8086&DEV_10C4
Found PCI\VEN_8086&DEV_10C4 in e1e5132.inf
[S] Packet len = 0xd0 (208)
[S] Result code: 0x0
[S] type: 0x2
[S] base offset = 0x24 (36)
[S] drv_off = 0x50 (80)
[S] srv_off: 0x68 (104) -> 96 from start
[S] plen: 0x5c (92)
[S] p_off: 0x7c (124) -> 116 from start
[S] hid: PCI\VEN_8086&DEV_10C4 - Len 0x15 (21)
[S] drv: e1e5132.sys - Len 0xb (11)
[S] srv: e1express - Len 0x9 (9)
[S] Description (REG_EXPAND_SZ [2]) = Intel(R) 82562GT 10/100 Network Connection
[S] Characteristics (REG_SZ [1]) = 132
[S] BusType (REG_SZ [1]) = 5
[S] Total Params: 3
Recv NCQ len = 48
NCQ Driver request
[R] Mac address 00:0c:29:91:6a:8a
[R] Vid: 0x1022
[R] Pid: 0x2000
[R] rev_u1 = 0x2
[R] rev_u2 = 0x0
[R] rev_u3 = 0x0
[R] rev = 0x10
[R] rev2 = 0x200
[R] subsys = 0x20001022
[R] Source path: \\%SERVERNAME%\Reminst\wxp-pro.rus
Checking PCI\VEN_1022&DEV_2000&SUBSYS_20001022
Checking PCI\VEN_1022&DEV_2000
Found PCI\VEN_1022&DEV_2000 in netamd2.inf
[S] Packet len = 0xb8 (184)
[S] Result code: 0x0
[S] type: 0x2
[S] base offset = 0x24 (36)
[S] drv_off = 0x50 (80)
[S] srv_off: 0x6a (106) -> 98 from start
[S] plen: 0x4a (74)
[S] p_off: 0x76 (118) -> 110 from start
[S] hid: PCI\VEN_1022&DEV_2000 - Len 0x15 (21)
[S] drv: pcntpci5.sys - Len 0xc (12)
[S] srv: PCnet - Len 0x5 (5)
[S] Description (REG_EXPAND_SZ [2]) = AMD PCNET PCI Ethernet
[S] Characteristics (REG_SZ [1]) = 132
[S] BusType (REG_SZ [1]) = 5
[S] Total Params: 3

Проверь winnt.sif на наличие %SERVERNAME%. Найденое замени на ip адрес твоего сервера.
root
Site Admin
 
Сообщения: 439
Зарегистрирован: 20 июл 2006, 00:45

Сообщение _alexander_ » 30 апр 2008, 09:50

root писал(а):
Проверь winnt.sif на наличие %SERVERNAME%. Найденое замени на ip адрес твоего сервера.


Тоже самое.

Вот часть моего winnt.sif

[Data]
AutoPartition=0
MsDosInitiated="0"
UnattendedInstall="Yes"
floppyless="1"
; OriSrc="\\%SERVERNAME%\Reminst\%INSTALLPATH%"
OriSrc="\\192.168.1.4\Reminst\wxp-pro.rus\i386"
OriTyp="4"
LocalSourceOnCD=1

[SetupData]
; параметры запуска Windows с tftp
OsLoadOptions="/noguiboot /fastdetect"
; откуда будет происходить сетевая установка
; SetupSourceDevice = "\Device\LanmanRedirector\%SERVERNAME%\Reminst\wxp-pro.rus"
SetupSourceDevice = "\Device\LanmanRedirector\192.168.1.4\Reminst\wxp-pro.rus"

Т.е., что при строках содержащих %SERVERNAME%, что с IP адресом - тоже самое.

Также еще пробовал удалять "fastdetect" в строке OsLoadOptions="/noguiboot /fastdetect", как и вообще удалять эту строку.

Результат тот же.
_alexander_
 
Сообщения: 23
Зарегистрирован: 29 апр 2008, 16:34
Откуда: Новый Уренгой

Сообщение root » 30 апр 2008, 10:11

Нужны логи tftp. Попробуй посмотреть /var/log/messages или /var/log/syslog.
Я бы еще обновил BIOS компьютера.
root
Site Admin
 
Сообщения: 439
Зарегистрирован: 20 июл 2006, 00:45

Сообщение _alexander_ » 30 апр 2008, 10:35

/var/log/syslog отсутствует.

/var/log/messages

Apr 30 13:29:14 srvuto01 dhcpd: DHCPDISCOVER from 00:1c:c4:ad:2b:f8 via eth1
Apr 30 13:29:15 srvuto01 dhcpd: DHCPOFFER on 192.168.1.153 to 00:1c:c4:ad:2b:f8 via eth1
Apr 30 13:29:16 srvuto01 dhcpd: DHCPREQUEST for 192.168.1.153 (169.254.211.115) from 00:1c:c4:ad:2b:f8 via eth1
Apr 30 13:29:16 srvuto01 dhcpd: DHCPACK on 192.168.1.153 to 00:1c:c4:ad:2b:f8 via eth1
Apr 30 07:29:16 srvuto01 in.tftpd[2985]: tftp: client does not accept options
Apr 30 13:30:15 srvuto01 dhcpd: DHCPDISCOVER from 00:0c:29:60:66:06 via eth1
Apr 30 13:30:16 srvuto01 dhcpd: DHCPOFFER on 192.168.1.162 to 00:0c:29:60:66:06 via eth1
Apr 30 13:30:17 srvuto01 dhcpd: DHCPREQUEST for 192.168.1.162 (169.254.211.115) from 00:0c:29:60:66:06 via eth1
Apr 30 13:30:17 srvuto01 dhcpd: DHCPACK on 192.168.1.162 to 00:0c:29:60:66:06 via eth1
Apr 30 07:30:17 srvuto01 in.tftpd[3014]: tftp: client does not accept options

192.168.1.162 - wmware
192.168.1.153 - xw9400.

"in.tftpd[3014]: tftp: client does not accept options" появляется при обоих загрузках. Однако в Vmware (последняя) загрузка проходит на ура, а в xw9400 - ошибка.

Пробовал удалять winnt.sif из /tftpboot, ошибка остается прежней.
Т.е. получается до обращения к winnt.sif еще не доходит...

ЗЫ: Про bios тоже думал. Машина довольно свежая, и на сайте HP в download указана версия BIOS, используемая в данный момент.
_alexander_
 
Сообщения: 23
Зарегистрирован: 29 апр 2008, 16:34
Откуда: Новый Уренгой

Сообщение root » 30 апр 2008, 11:45

Нет без логов все равно не понять.
Попробуй в строку запуска tftp сервера добавить -v.
Код: Выделить всё
-v  Increase the logging verbosity of tftpd . This flag can be specified multiple times for even higher verbosity.
Взято с man tftpd
root
Site Admin
 
Сообщения: 439
Зарегистрирован: 20 июл 2006, 00:45

След.

Вернуться в Установка Windows XP по сети. RIS, но не Microsoft

Кто сейчас на конференции

Сейчас этот форум просматривают: Yahoo [Bot] и гости: 1

cron
@Mail.ru