Не копируется $OEM$ и не ставятся драйвера...

Обсуждение статьи "Установка Windows XP по сети. RIS, но не Microsoft"

Модераторы: editor, Devils

Сообщение qw-0 » 22 мар 2008, 14:01

slech писал(а):пробовал и
OEMPnPDriversPath="DRIVERS\SCSI"
результат тот же.

Это строка сообщает где искать драйвера во время графической стадии установки. В текстовом режиме не используется.
slech писал(а):я и со строчкой d5 = "Promise FastTrak Family Driver Diskette", \fasttrak, \
пытался шаманить, ничего не вышло.

Я бы попробывал следующее. Переместил бы строку d5 выше d1.
Скопировал файл FASTTRAK в директорию TEXTMODE
qw-0
 
Сообщения: 164
Зарегистрирован: 13 апр 2007, 01:20

Сообщение slech » 22 мар 2008, 16:14

не помогло. я уже начинаю сомневаться в правильности выбраного драйвера.
этот способ вооще у кого-нибудь работает ?
дело в том что сервер в другой стране и у меня только IP KVM.
В биосе не видать ничего. Физически не посмотреть.
По данным из Windows там стоял Win.NET Promise FastTrak100 Controller
Вроде именно для него я и нашёл драйвера.
slech
 
Сообщения: 89
Зарегистрирован: 22 мар 2008, 02:34

Сообщение slech » 22 мар 2008, 16:19

может единственный вариант это интеграция в дистрибутив ?
с помощью N-Lite или ручками.
Меня смущает тот факт что Microsoft в своей иструции говорит о перегрузке сервиса BINL.
Он используется только для драйверов сетевых карт ?
slech
 
Сообщения: 89
Зарегистрирован: 22 мар 2008, 02:34

Сообщение qw-0 » 22 мар 2008, 16:50

slech писал(а):может единственный вариант это интеграция в дистрибутив ?
с помощью N-Lite или ручками.
Меня смущает тот факт что Microsoft в своей инструции говорит о перегрузке сервиса BINL.
Он используется только для драйверов сетевых карт ?

BINL здесь не причем. А перезагружать его нужно для того чтобы переформировать базу устройств и по-моему только для сетевых адаптеров, ну и еще что бы файлф ответов перечитать.
Попробуй вот этот файл
Код: Выделить всё
[Disks]
d1 = "Promise FastTrak Family Driver Diskette", \Fasttrak.sys, \
[Defaults]
scsi = FastTrak_TX2_net
[scsi]
FastTrak_TX2000_net = "Win.Net Server 2003 Promise FastTrak TX2000 (tm) Controller"
FastTrak_TX2_net = "Win.Net Server 2003 Promise FastTrak100 TX2/TX4 (tm) Controller"
Fasttrak100_net = "Win.Net Server 2003 Promise FastTrak100 (tm) Controller"
Fasttrak66_net = "Win.Net Server 2003 Promise FastTrak66 (tm) Controller (PDC20262)"
[Files.scsi.FastTrak_TX2000_net]
driver = d1, Fasttrak.sys, Fasttrak
inf    = d1, Fasttrak.inf
[HardwareIds.scsi.FastTrak_TX2000_net]
id="PCI\VEN_105A&DEV_6269", "Fasttrak"
[Files.scsi.FastTrak_TX2_net]
driver = d1, Fasttrak.sys, Fasttrak
inf    = d1, Fasttrak.inf
[HardwareIds.scsi.FastTrak_TX2_net]
id="PCI\VEN_105A&DEV_6268", "Fasttrak"
[Files.scsi.Fasttrak100_net]
driver = d1, Fasttrak.sys, Fasttrak
inf    = d1, Fasttrak.inf
[HardwareIds.scsi.Fasttrak100_net]
id="PCI\VEN_105A&DEV_4D30&SUBSYS_4D39105A", "Fasttrak"
id="PCI\VEN_105A&DEV_4D30&SUBSYS_4D32105A", "Fasttrak"
[Files.scsi.Fasttrak66_net]
driver = d1, Fasttrak.sys, Fasttrak
inf    = d1, Fasttrak.inf
[HardwareIds.scsi.Fasttrak66_net]
id="PCI\VEN_105A&DEV_4D38&SUBSYS_4D39105A", "Fasttrak"
[Files.scsi.Fasttrak_net]
driver = d1, Fasttrak.sys, Fasttrak
inf    = d1, Fasttrak.inf
[HardwareIds.scsi.Fasttrak_net]
id="PCI\VEN_105A&DEV_4D33&SUBSYS_4D33105A", "Fasttrak"
[Config.Fasttrak]
value = "", Tag, REG_DWORD, 1

Возможно прийдется поиграться со строкой d1.
    d1 = "Promise FastTrak Family Driver Diskette", Fasttrak.sys, \
    d1 = "Promise FastTrak Family Driver Diskette", \Fasttrak.sys, .
    d1 = "Promise FastTrak Family Driver Diskette", Fasttrak.sys, .
    d1 = "Promise FastTrak Family Driver Diskette", Fasttrak.sys, ""
Кстати в winnt.sif можно прописать так:
Код: Выделить всё
[MasStorageDrivers]
"Win.Net Server 2003 Promise FastTrak TX2000 (tm) Controller"= "OEM"
"Win.Net Server 2003 Promise FastTrak100 TX2/TX4 (tm) Controller"= "OEM"
"Win.Net Server 2003 Promise FastTrak100 (tm) Controller"= "OEM"
"Win.Net Server 2003 Promise FastTrak66 (tm) Controller (PDC20262)"= "OEM"
"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"
qw-0
 
Сообщения: 164
Зарегистрирован: 13 апр 2007, 01:20

Сообщение slech » 22 мар 2008, 21:54

мдя, никак :(
может чтото не то делаю
попробую всё заново начать.
qw-0 - спасибо за помощь. буду продолжать поиски.
у тебя такой способ работает ?
slech
 
Сообщения: 89
Зарегистрирован: 22 мар 2008, 02:34

Сообщение qw-0 » 23 мар 2008, 00:57

slech писал(а):мдя, никак :(
может чтото не то делаю
попробую всё заново начать.
qw-0 - спасибо за помощь. буду продолжать поиски.
у тебя такой способ работает ?

Нет Fasttrack мне еще не попадался. Это я на основе опыта с Intel.
qw-0
 
Сообщения: 164
Зарегистрирован: 13 апр 2007, 01:20

Сообщение slech » 24 мар 2008, 11:26

попытка №2
если рассмотреть

winnt.sif

[data]
AutoPartition=0
MsDosInitiated=0
UnattendedInstall="Yes"
OriSrc="\\172.16.1.1\2k3EEsp1en\Install\I386"
OriTyp="4"

[SetupData]
OsLoadOptions = "/noguiboot /fastdetect"
SetupSourceDevice = "\Device\LanmanRedirector\172.16.1.1\2k3EEsp1en\Install"
на сколько важно что бы пути эти различались на i386

Пробую на Dell Power Edge 2950
там RAID котроллер
DELL PERC5 and PERC6/CERC6 RAID Controller Driver (Server 2003 32 bit)
в отличии от истории описанной выше сейчас происходило долгое копирование драйверов для различных контролеров, но к сожалению в списке своего я так и не увидел, и не нашла система его.
Пока продолжаю попытки.
Поэтому предпологаю что в 1-вом случае наверное всё же проблема на этапе установки netbios соединения.

причём если мосмотреть на машине где RIS
>net session
\\172.16.1.160 GUEST
вот для гостя я и разрешал. может это и помогло
slech
 
Сообщения: 89
Зарегистрирован: 22 мар 2008, 02:34

Сообщение slech » 24 мар 2008, 11:50

опять нивкакую
мой RAID контроллер PERC 5/i Integrated
вот сыллка на драйвер, я подправил , но оно не хочет работать.
кто может помочь ?
slech
 
Сообщения: 89
Зарегистрирован: 22 мар 2008, 02:34

Сообщение root » 24 мар 2008, 13:16

slech писал(а):опять нивкакую
мой RAID контроллер PERC 5/i Integrated
вот сыллка на драйвер, я подправил , но оно не хочет работать.
кто может помочь ?

А ты добавил строку
Код: Выделить всё
[MassStorageDrivers]
"DELL PERC5 and PERC6/CERC6 RAID Controller Driver (Server 2003 32 bit)" = "OEM"
root
Site Admin
 
Сообщения: 439
Зарегистрирован: 20 июл 2006, 00:45

Сообщение slech » 24 мар 2008, 13:18

есть ошибка у меня

[MasStorageDrivers] # [MassStorageDrivers]
"DELL PERC5 and PERC6/CERC6 RAID Controller Driver (Server 2003 32 bit)"= "OEM"
"IDE CD-ROM (ATAPI 1.2)/PCI IDE Controller" = "RETAIL"

буду пробовать снова
Последний раз редактировалось slech 24 мар 2008, 13:23, всего редактировалось 3 раз(а).
slech
 
Сообщения: 89
Зарегистрирован: 22 мар 2008, 02:34

Пред.След.

Вернуться в Установка Windows XP по сети. RIS, но не Microsoft

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron
@Mail.ru